看股吧 www.kanguba.com [今日大盘指数 欧美全球股市行情 股票公式查询网站] 关闭本站广告
看股吧
看股吧股票网-今日大盘指数 欧美全球股市行情 股票公式查询网站
股票查询: 行情分析 DDX指标 走势点评 股票公告 大事 主力持仓 股权质押 分红 限售解禁 十大股东 股本 高管持股 高管 主营 龙虎榜 股吧
当前位置: 看股吧 > 股票公式 > 公式正文 股票指标公式:
选股公式 主图公式 分时指标 短线指标 副图公式 黑马公式 涨停指标 牛股公式 画线公式 趋势指标 波段指标 买卖指标 抄底公式 逃顶公式 顶底公式 主力指标 散户指标 机构指标 庄家指标 私募指标 资金指标 量能指标 筹码指标 成本指标 k线指标 均线公式 量比指标 成交量公式 换手率公式 macd指标 kdj指标 rsi指标 cci指标 boll指标 dmi指标 vol指标 obv指标 bias指标 ddx指标 通达信 大智慧 同花顺 飞狐

通达信主力动向趋势操盘指标公式

2020/9/14 19:39:23

通达信主力动向趋势操盘指标公式:

A:=CURRBARSCOUNT;
A1:=DAY!=REF(DAY,1);
A2:=BARSLAST(A1)+1;
A3:=MA(C,A2);
A4:=SUM(AMO,A2)/SUM(VOL,A2)/100;
A5:=IF(CAPITAL>0,A4,A3);
均价线:=IF(A<=CONST(A2),A5,DRAWNULL);
分钟有效周期:=IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,DRAWNULL))));
分时价:=TFILT(CLOSE,CURRBARSCOUNT,00,CURRBARSCOUNT,00);
分时判断:=IF(分时价=DRAWNULL,1,IF(分钟有效周期=DRAWNULL,DRAWNULL,1));
{-----------------------------由MACD定位顶底-------------------------------}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
KX:=BARSSINCE(CLOSE);{←首次开盘价距金的天数}
HHN:=CONST(HHV(DIFF,KX));
HLN:=CONST(LLV(DEA,KX));
RC1:=CONST((HHN+HLN)/2);
SS:=((HHN-HLN)/200);
MACD底部:=(-100*SS+RC1)+-(-100*SS+RC1),COLOR669999;
MACD顶部:=(100*SS+RC1)+-(-100*SS+RC1),COLORFF0033;
MACD中轴:=0+-(-100*SS+RC1);
DIFF修正:=DIFF+-(-100*SS+RC1),COLOR008080;
DEA修正:=DEA+-(-100*SS+RC1),COLOR00FF00;
MACD修正:=2*(DIFF修正-DEA修正)+MACD中轴,COLOR0000BB,NODRAW;
MACD超跌:=CONST(LLV(MACD修正,KX));
MACD超跌线:=IF(MACD超跌<MACD底部,MACD超跌,MACD底部);
{----------------------利用MACD趋势进行精确顶底判断------------------------}
顶部:=MACD顶部+-MACD超跌线;
天际:=顶部*0.809;
中轴:=MACD中轴+-MACD超跌线;
海面:=顶部*0.191;
底部:=MACD底部;
{------------------------传统KDJ指标结合MACD优化---------------------------}
RSVA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*顶部;{采用21日月线优化}
K:SMA(RSVA,3,1),COLORFFFFFF,NODRAW;
D:SMA(K,3,1),COLOR00FFFF,NODRAW;
原J值参数:=3*K-2*D;
JD:=IF(原J值参数<底部,底部,原J值参数);{J值底部钝化处理}
J:IF(JD>顶部,顶部,JD),COLORFF00FF,NODRAW;{底部钝化处理后再进行顶部钝化处理}
{---------------------------MACD多空量能判断-------------------------------}
MACD多头:DIFF修正+-MACD超跌线,COLOR339999;
空头:DEA修正+-MACD超跌线,COLOR00FF00;
量能柱:2*(MACD多头-空头)+中轴,COLOR0000BB,NODRAW;
超前DEA:=(EMA(MACD多头,7));
超前MACD:=2*(MACD多头-超前DEA)+中轴;
{-----------------------------------大盘动向-------------------------------}
VAR1大盘:=LLV(LOW,13);
VAR2大盘:=HHV(HIGH,13);
VAR3大盘:=(SMA((CLOSE-VAR1大盘)/(VAR2大盘-VAR1大盘)*顶部,5,1))-顶部/2;
VAR4大盘:=SMA((VAR2大盘-CLOSE)/(VAR2大盘-VAR1大盘)*顶部,5,1)-顶部/2;
大盘散户:=IF(VAR4大盘<底部,底部,VAR4大盘),COLOR408000;
大盘主力:=IF(VAR3大盘<底部,底部,VAR3大盘),COLOR330088;
{---------------------------------密集成本突破-----------------------------}
最高获利参数:=顶部/100;
VAR1C:=(COST(89)-COST(11))*最高获利参数;
VAR2C:=(COST(99.9)-COST(1))*最高获利参数;
单峰:=((1-VAR1C/VAR2C))*顶部;
低密:=((COST(90)-COST(60))/VAR2C)*顶部;
高密:=((COST(40)-COST(1))/VAR2C)*顶部;
赢利:= (SMA(WINNER(AMOUNT/VOL/99),2,1))*顶部;
活跃度:顶部-顶部/(1+EXPMA(HSL,21)),COLOR774455;{←CYF公众追涨热情指标}
70%成本集中度:=IF(VAR1C>顶部,顶部,VAR1C),COLORFFFFFF;
90%成本集中度:=IF(VAR2C>顶部,顶部,VAR2C),COLORFF0000;
套牢筹码上升:=IF((单峰-赢利)>底部,(单峰-赢利),底部);
个股散户:=IF(套牢筹码上升>顶部,顶部,套牢筹码上升),COLOR408000;
散户:IF(个股散户=DRAWNULL,DRAWNULL,个股散户),COLOR408000;
获利筹码上升:=IF((赢利-单峰)>底部,(赢利-单峰),底部);
个股主力:=IF(获利筹码上升>顶部,顶部,获利筹码上升),COLOR330088;
主力:IF(个股主力=DRAWNULL,DRAWNULL,个股主力),COLOR330088;
{--------------------换手率,五日换手率辅助判断个股活跃度-------------------}
换手:SUM(VOL,1)/CAPITAL*100,COLOR666666,NODRAW;
⑤日换:SUM(VOL,5)/CAPITAL*100,COLOR999999,NODRAW;
{----------------------密集成本突破指标筹码峰画线--------------------------}
金色背景修边1:STICKLINE(C>0 AND CURRBARSCOUNT>=2,顶部,底部,3.05,0),COLOR003333;
金色背景修边2:STICKLINE(C>0 AND CURRBARSCOUNT>=2,顶部,中轴,3.05,0),COLOR003333;
金色背景补充:DRAWBAND(顶部,RGB(51,51,0),中轴,RGB(51,51,0));
金色背景:DRAWBAND(顶部,RGB(51,51,0),底部,RGB(128,128,128));
追涨热度峰紫色:DRAWBAND(活跃度,RGB(66,52,81),底部,RGB(204,0,0));
高密峰墨蓝色:=DRAWBAND(高密,RGB(0,0,51),底部,RGB(0,0,255));
低密峰纯蓝色:=DRAWBAND(低密,RGB(0,0,102),底部,RGB(0,0,255));
90%成本峰:DRAWBAND(90%成本集中度,RGB(0,0,153),底部,RGB(0,0,153));
70%成本峰:DRAWBAND(70%成本集中度,RGB(0,128,0),底部,RGB(255,255,255));
散户峰绿色:DRAWBAND(散户,RGB(0,64,0),底部,RGB(204,0,0));
主力峰红色:DRAWBAND(主力,RGB(102,26,51),底部,RGB(0,0,255));
MACD多空趋势:DRAWBAND(MACD多头,RGB(204,51,51),空头,RGB(0,179,0));
MACD多头重画:DRAWBAND(MACD多头,RGB(153,153,51),MACD多头,RGB(153,153,51));
MACD空头重画:DRAWBAND(空头,RGB(0,204,0),空头,RGB(0,204,0));
{--------理想论坛‘131488’会员提供的通达信■新宝塔线■-----原码-----------}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
三平底翻金:=(REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1))
AND VAR1;
主力启动线:=MA(V,5),COLORFFFFFF;
主力洗盘线:=MA(V,35),COLOR00FFFF;
资金异动线:=MA(V,135),COLORFF0000;
{----------------------------买卖参考--------------------------------------}
出击:=(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线))),COLORYELLOW;
启动:=(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) OR REF(VOL,2)<REF(资金异动线,2)))),COLOR45AAEE;
成立:=三平底翻金 AND (出击 OR 启动);
买入提示:=IF(成立=1,海面*0.5,0) AND 分时判断=1;
{------------------------顶部线,天际线,海面线,底部线重画-------------------}
顶部线:DRAWBAND(顶部,RGB(51,0,255),顶部,RGB(51,0,255));
天际线:DRAWBAND(天际,RGB(128,64,64),天际,RGB(128,64,64));
海面线:DRAWBAND(海面,RGB(0,153,153),海面,RGB(0,153,153));
底部线:DRAWBAND(0,RGB(153,153,102),买入提示,RGB(153,153,102));
{------------------------超前MACD多空量能柱--------------------------------}
超前MACD红柱1:STICKLINE(超前MACD>=中轴,超前MACD,中轴,1.50,0),COLOR226688;
超前MACD红柱2:STICKLINE(超前MACD>=中轴,超前MACD,中轴,0.95,0),COLOR4488BB;
超前MACD红柱3:STICKLINE(超前MACD>=中轴,超前MACD,中轴,0.31,0),COLOR55AADD;
超前MACD兰柱1:STICKLINE(超前MACD<=中轴,超前MACD,中轴,1.50,0),COLOR006600;
超前MACD兰柱2:STICKLINE(超前MACD<=中轴,超前MACD,中轴,0.95,0),COLOR007700;
超前MACD兰柱3:STICKLINE(超前MACD<=中轴,超前MACD,中轴,0.31,0),COLOR008800;
{--------------------------MACD多空量能柱----------------------------------}
MACD红柱1:STICKLINE(量能柱>=中轴,量能柱,中轴,1.5,0),COLOR000077;
MACD红柱2:STICKLINE(量能柱>=中轴,量能柱,中轴,1.1,0),COLOR000088;
MACD红柱3:STICKLINE(量能柱>=中轴,量能柱,中轴,0.6,0),COLOR000099;
MACD红柱4:STICKLINE(量能柱>=中轴,量能柱,中轴,0.15,0),COLOR0000AA;
MACD兰柱1:STICKLINE(量能柱<=中轴,量能柱,中轴,1.5,0),COLORAA6633;
MACD兰柱2:STICKLINE(量能柱<=中轴,量能柱,中轴,1.1,0),COLORBB7744;
MACD兰柱3:STICKLINE(量能柱<=中轴,量能柱,中轴,0.6,0),COLORCC8855;
MACD兰柱4:STICKLINE(量能柱<=中轴,量能柱,中轴,0.15,0),COLORDD9966;
{---------中轴线重画及顶部线,天际线,海面线,底部线,多空线文字说明-----------}
中轴线:DRAWBAND(中轴,RGB(128,128,255),中轴,RGB(128,128,255));
顶部线文字:DRAWTEXT(CURRBARSCOUNT=1,顶部*0.98,' 顶部线'),COLORFF0033;
天际线文字:DRAWTEXT(CURRBARSCOUNT=1,天际*0.98,' 天际线'),COLOR404080;
海面线文字:DRAWTEXT(CURRBARSCOUNT=1,海面,' 海面线'),COLOR999900;
底部线文字:DRAWTEXT(CURRBARSCOUNT=1,底部,' 底部线'),COLOR669999;
中轴线文字:DRAWTEXT(CURRBARSCOUNT=1,中轴,' 多空线'),COLORFF8080;
{-------------------------------传统KDJ指标线重画--------------------------}
D线重画:DRAWBAND(D,RGB(255,255,0),D*0.998,RGB(255,255,0));
K线重画:DRAWBAND(K,RGB(255,255,255),K,RGB(255,255,255));
J线重画:DRAWBAND(J,RGB(255,0,255),J,RGB(255,0,255));

通达信主力动向趋势操盘指标公式

其它股票公式展示
在线查股
网站合作:在线客服
看股网力求但不保证数据的完全准确,不对因网站全部内容或部分内容而引致的盈亏承担任何责任,本站所有内容仅供参考。粤ICP备16041854号-1
本站不提供任何股票服务,站内广告不代表看股吧的观点,由此引起的一切法律责任均与本站无关,请股民自行识别判断,谨慎投资,预防上当受骗!
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)